馬在中國象棋以日字形規則移動。
請編寫一段程式,給定n*m大小的棋盤,以及馬的初始位置(x,y),要求不能重複經過棋盤上的同一個點,計算馬可以有多少途徑遍歷棋盤上的所有點。
Input
第一行為整數T(T < 10),表示測試資料組數。
每一組測試資料包含一行,為四個整數,分別為棋盤的大小以及初始位置座標n,m,x,y。(0<=x<=n-1,0<=y<=m-1, m < 10, n < 10)
Output
每組測試資料包含一行,為一個整數,表示馬能遍歷棋盤的途徑總數,0為無法遍歷一次。
Sample Input
1
5 4 0 0
Sample Output
32
#include<bits/stdc++.h>
using namespace std;
int book[11][11];
int n,m,sum;
int next[8][2]={{1,2},{-1,2},{1,-2},{-1,-2},{2,1},{-2,1},{2,-1},{-2,-1}};
void dfs(int x,int y,int step)
{
if(step==n*m)
{
sum++;
return;
}
int tx,ty;
for(int i=0;i<8;i++)
{
tx=x+next[i][0];
ty=y+next[i][1];
if(tx>=0&&tx<n&&ty>=0&&ty<m)
{
if(book[tx][ty]==0)
{
book[tx][ty]=1;
dfs(tx,ty,step+1);
book[tx][ty]=0;
}
}
}
}
int main()
{
int t;
cin>>t;
while(t--)
{
int stax,stay;
cin>>n>>m>>stax>>stay;
memset(book,0,sizeof(book));
sum=0;
book[stax][stay]=1;
dfs(stax,stay,1);
cout<<sum<<endl;
}
return 0;
}